[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] bootstrap error on Mandriva 2010

From: Rogerio Luz Coelho
Subject: Re: [Gnumed-devel] bootstrap error on Mandriva 2010
Date: Sun, 7 Mar 2010 12:36:43 -0300

So what this is saying is that a Mandriva 2010 PostgreSQL cannot install gnumed-server in unicode?

Can I install the PostgreSQL source and get it to unicode?

Or can I just install the server with unicode if I give it some installation parameters ?


2010/3/7 Karsten Hilbert <address@hidden>
> I dont know, where is the problem.

> ==> cloning [template1] (5280 kB) as target database [gnumed_v2] ...


> Bootstrapping "gnumed_v12" did not finish successfully. Aborting.

> bootstrap-latest.log:
> 2010-03-06 19:58:03  ERROR     gm.bootstrapper
> (./ #781): >>>[
>                                 create database "gnumed_v2" with
>                                         owner = "gm-dbo"
>                                         template = "template1"
>                                         encoding = 'unicode'
>                                 ;]<<< failed
> Traceback (most recent call last):
>   File "./", line 779, in __create_db
>     cursor.execute(cmd)
>   File "/usr/lib/python2.6/site-packages/psycopg2/", line 110,
> in execute
>     return _cursor.execute(self, query, vars, async)
> DataError: new encoding (UTF8) is incompatible with the encoding of the
> template database (SQL_ASCII)
> TIP:  Use the same encoding as in the template database, or use
> template0 as template.

It is not possible to create a unicode database (with utf8 encoding)
from a SQL-ASCII template.

- use another template
- re-initdb the cluster
- use another cluster

Those are the options.


Sicherer, schneller und einfacher. Die aktuellen Internet-Browser -
jetzt kostenlos herunterladen!

Gnumed-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]