[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Groff] installing 1.18.1 on an iMac

From: Larry Kollar
Subject: Re: [Groff] installing 1.18.1 on an iMac
Date: Tue, 22 Oct 2002 22:21:27 -0400

Gaius Mulley <address@hidden> wrote:

> has anyone successfully compiled groff 1.18.1 or cvs snapshot 1.18.2
> onto a iMax G4 running Jaguar (Mac OS 10.2.1)?

Robert Marks has (see the "1.18.1 with mm overflow problem"
thread). The problem he's having is a bug introduced into
m.tmac between 1.17.2 and 1.18.1 (I see it on my Debian
laptop). I'll know more tomorrow when I compile it at work
(just installed OSX 10.2 today on my work computer).

>    'sudo ./configure' ...
>       It found four programs to be missing (pnmcut, pnmcrop, pnmtopng, and
>       psselect) and said that, ... grohtml) wouldn't work properly...

Those programs are part of the netpbm package. That's
available from fink, if you've upgraded it to work with 10.2.

>       But a large number of "can't break line" messages were generated to
>       standard error *.n files were being made from *.man files.

That sounds like errors I get on Linux when groff'ing a
file with DOS-style or Mac-style line breaks. I've learned
that MacOS X Terminal apps expect the Unix line break, not
the Mac line break. I wonder whether the automatic unpacking
(Stuffit Expander) "fixed" the text files to have Mac line

If the original .tar.gz file is available, delete the current
source, unpack it again from the Terminal:
        gunzip -c groff-1.18.1.tar.gz | tar xf -
and try rebuilding the source.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]