[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Configure options questions

From: jlcenter
Subject: Configure options questions
Date: Tue, 20 Mar 2012 02:59:30 +0000 (UTC)


I built the latest version of grub with the following configure options:

./configure --prefix=/ --exec-prefix=/usr --datarootdir=/usr/share 

This seemed like this matched the Ubuntu locations.  I ran grub-install & it 
reconfigured the old /boot/grub directory like this:

address@hidden:/boot/grub# ls
core.efi    fonts     grub.efi  i386-pc   locale  grub.cfg  grubenv   load.cfg  themes

I was a pleasantly surprised how the grub directory was reorganized, though 
some of the old files ( were left behind.  After I rebooted, I got 
errors that grub couldn't find the various modules that used to be in 
/boot/grub, but are now in /boot/grub/i386-pc.  Did I misconfigure something in 
the configure options?  

After rebooting with a livecd, I looked at the grub.cfg file & saw that 
"$prefix" is still there, instead of the entry from 00_header.  I ran 
grub-mkconfig by hand & it didn't change & I didn't see any errors.  Is this 
related to the problem above?

Any help would be greatly appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]