[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: memory.text

From: Marius Vollmer
Subject: Re: memory.text
Date: 27 Nov 2001 00:05:54 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.1

Dirk Herrmann <address@hidden> writes:

> On 25 Nov 2001, Marius Vollmer wrote:
> > > What about naming the function scm_make_cell, or scm_new_cell?
> > 
> > I named it scm_alloc_cell and scm_alloc_double_cell.  Not sure if that
> > are better names than yours... 
> Ah, I hadn't realized that you already had submitted your patches.  Still,
> I like the scm_make_cell and scm_make_double_cell names better...  Maybe
> we should have a voting :-)

Yeah, why not.

> A different thing:  Why did you extract the inline functions to inline.h?

I wanted to provide a mechanism for easily adding inline functions to
Guile, with support for platforms where inlining doesn't work.  I
think the code for only-potentially inlined functions is sufficiently
different from ordinary declarative code that it should be kept to its

This might not lead to a good grouping, but the documentation and TAGS
can make up for this.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]