[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guile-gnome-0 - guile-1.6.8-6.3 - random crash

From: David Pirotte
Subject: Re: guile-gnome-0 - guile-1.6.8-6.3 - random crash
Date: Sat, 10 Apr 2010 11:23:39 -0300

Le Thu, 08 Apr 2010 20:53:17 +0200,
Andy Wingo <address@hidden> a écrit :

> Hi David,
> I'm happy to help, and glad to hear things are going OK. You probably
> have the largest guile-gnome-using apps out there... Also, one of these
> three lists is probably enough ;)

:-) left guile-devel only this time

> On Thu 08 Apr 2010 20:06, David Pirotte <address@hidden> writes:
> ...

> I just downloaded
> and it seems to compile fine against 2.0. I did a (load-extension
> "./libgtrees" "define_gtrees_module") and that worked, and then
> (use-modules (gtrees-module)) and that worked too.

Yes. Just made things working both with guile-1.6 and guile-1.8 [on the same
machine I mean], by changing the module definition as this [if others would 
like to
do so...]:

;; --
(define-module (struct gtrees))

(let ((ef-ver (string->symbol (effective-version))))
  (case ef-ver
     (dynamic-call "init_gtrees_module"
                   (dynamic-link "/usr/local/lib/gtrees-0.3/")))
     (dynamic-call "init_gtrees_module"
                   (dynamic-link "/usr/local/lib/gtrees-0.5/")))
;; --

> Perhaps you will be able to skip 1.8 ;-) But it should work with 1.8 as well.

Well, as much as possible, due to the amount of work I have, I'll stick to 
packages until I finish the application I am working on, then I'll try 2.0 and
guile-vm, I can't wait! but I have to :-(

> >     guile-1.8 and guile-pg, a prehistoric version which will remain so until
>                       ^^ 

> No such luck with guile-pg, it will need patches. I even tried applying
> debian's patches to see if that would help, but guile-pg uses gh.h.
> Copying Thien-Thi, who appears to be the upstream: what is the right
> thing to do here? Get it into a project on savannah in git hosting, no?

If you remember, thanks to dsmith, on xchat, I could produce a guile-pg [debian]
package patched that works with guile-1.8 [the problem was a dependency one: 
here is
what I wrote to myself:

;;; Debian package [patching guile-pg-0.16]

A] Getting the source

        cd ~/alto/admin/guile-pg
        apt-get build-dep guile-pg
        apt-get source guile-pg
        cd guile-pg-0.16

B] Changing the dependency towards guile-1.8
        cd guile-pg-0.16/debian
   perform the following change

<       Build-Depends: debhelper (>> 4.0), quilt, libpq-dev, guile-1.6-dev
>       Build-Depends: debhelper (>> 4.0), quilt, libpq-dev, guile-1.8-dev

        But I also wrote something about patching libpostgres.c and .h,
        [postgres-7.4: the only SW that's still is not a debian package [in my
        dependency 'little tower'] but a manual compilation [and they are @ 8.4 
        so quite late on this side too ...] can't find right now but if people 
        interested i'll make that info avalable too, let me know.

C] Then I changed the module definition [attached]

;; --

So I was wondering, in order to be as practicle as possible and save 'lost'
debugging time, is it possible to install both guile-gnom0 and guile-gnome2 on 
same machine ?

        I think I tried and didn't work, but I might be wrong.

That would fantastic because I could right away porting the development I am 
and later on port the old apps.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]