[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lost: guile 1.7.0 doesn't look to GUILE_LOAD_PATH ?

From: Thomas Wawrzinek
Subject: Re: lost: guile 1.7.0 doesn't look to GUILE_LOAD_PATH ?
Date: Wed, 29 Aug 2001 08:57:46 +0200 (MEST)


address@hidden wrote:

 >      open("/usr/local/lib/libpostgres", O_RDONLY) = -1 ENOENT (No such file 
 > or directory)
 > i don't know why it does it in 2 different ways neither what I  should do
 > to avoid it

Well, maybe my first guess (leaving out the extension, i.e.) was wrong after

You might try to play around with the extensions .la and .so in your

You could also try to use (load-extension "libpostgres" "init_postgres")
instead of the (dynamic-call ... (dynamic-link ...)) combination.

Then I've seen that your libtool library (postgres) was generated by libtool
1.3.4 whereas guile uses libtool 1.4 (I don't know whether this is

What baffles me is the repeated searching and loading of libpostgres and
libpq shown in your strace output.

I'd run ldd on any of these libs to see whether there are dependencies to
other versions of these libs are there (e.g. those from the installation you

Dynamic linking can be weird because you can manipulate it (with
LD_LIBRARY_PATH etc.) and it's not easy to figure out what's wrong (as you

Could be, that you've put your system in some inconsistent state ...



reply via email to

[Prev in Thread] Current Thread [Next in Thread]