[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: new slib and guile 1.6.7

From: Alan Grover
Subject: Re: new slib and guile 1.6.7
Date: Fri, 21 Oct 2005 16:06:54 -0400
User-agent: Mozilla Thunderbird 1.0.6 (X11/20050716)

I have the same problem with 1.6.4 (no surprise) and slib3a2.

First, Kevin Ryde once wrote me:
> Incidentally, the (ice-9 slib) module which comes with guile probably
> doesn't work with the latest slib, running up guile.init as described
> in the slib docs is the way to go.

I found that ice-9/slib had to be removed (and replaced at your
preference with something that loads slib/guile.init). Presumably
ice-9/slib should be removed from guile.

Second, I think there is a bug in slib/guile.init related to line 28:

(define software-type
  (if (string<? (version) "1.6")
      (lambda () 'UNIX)
      (lambda () 'unix)))

>From what I can tell, use of 'unix vs. 'UNIX is inconsistent throughout
guile.init (and thus causes problems with case-preserving symbols). I
punted and added both wherever either was used:

<          ((unix coherent ms-dos)      ;V7 unix has a / on HOME
>          ((UNIX unix coherent ms-dos) ;V7 unix has a / on HOME
<          ((unix coherent plan9)               '(#\/))
>          ((UNIX unix coherent plan9)          '(#\/))
<                  ((UNIX COHERENT PLAN9 AMIGA) "/"))))
>                  ((unix UNIX COHERENT PLAN9 AMIGA) "/"))))

And third, once you get the error, you must delete slibcat to try again.

And fourth, I have been too lazy to send this bug report to the slib
guy. Could you finish characterizing the behavior, and propose the
(better) fix to the slib guy?

Greg Troxel wrote:
> I'm investigating why in NetBSD pkgsrc the update of slib to 3a2
> breaks the guile-slib package, failing when it tries to build the
> catalog:
> cd /usr/pkg/share/guile/slib;  guile -q -s 
> /usr/pkgsrc/devel/guile-slib/files/ge
> ncat.scm
> ERROR: Unbound variable: with-load-pathname
> gencat.scm is provided by the guile-slib package and is really pretty
> simple:
> ; $NetBSD: gencat.scm,v 2000/02/23 20:36:47 jlam Exp $
> (use-modules (ice-9 slib))
> (slib:load "mklibcat")
> It seems that guile has (ice-9 slib) and does not use guile.init from
> slib.  I think (ice-9 slib) needs to have support for
> with-load-pathname for the new slib to work, but I don't really
> understand this.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]