[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h-e-w] Please test w32-shell-execute

From: Lennart Borgman
Subject: Re: [h-e-w] Please test w32-shell-execute
Date: Thu, 19 Nov 2009 21:12:51 +0100

On Thu, Nov 19, 2009 at 4:14 PM, Lennart Borgman
<address@hidden> wrote:
> On Thu, Nov 19, 2009 at 3:52 PM, Drew Adams <address@hidden> wrote:
>>> I get the same as you, Lennart.
>>> The last two do not open the browser, and they do not raise
>>> an error - they seem to do nothing.
>> I should have added that that is with the 23.1 Emacs release on Windows XP 
>> SP3,
>> using `emacs -Q'.
> Thanks for all responses. I think there must be some Registry entries
> responsible for the difference. Does anyone know which those might be?
> I guess the relavant entries are at
>   HKEY_CURRENT_USER\Software\Classes\file
> Could someone for whom it worked in all cases export these keys and
> send them here?

-------------------------------- Here is a big part saying I found no
important diffs so far --------------------------

I got some responses off list for this. John sent me these registry
keys and they look very similar to mine, except for two small

1) I have an EditFlags which John does not have. Tried renaming that
value, but that did not help.

@="Firefox Document"
"FriendlyTypeName"="Firefox Document"

2) He had some editor entries. Does not seem to be involved.

John has

  assoc .htm=htmlfile

while I have

  assoc .htm=FirefoxHTML

Our ftype for those are similar.

We also looked at "Add or Remove Programs -> Set Program Access and
Default". No differences there either.

* Summary John-me: It works for him, not for me. Only difference found
is assoc, but when I tried changing that I got the same result.
(However I am unsure if Emacs needs to be restarted, I did not do

Drew has no file assoc for .html.

* Summary Drew-me: It does not work for anyone of us. assoc does not
seem to be involved.

----------------------- And now I will ask for some more help

I have got the feeling that file:/// URLs are incompletely setup for
me, but I am not sure. In Windows Explorer in the menus Tools - Folder
Options in then in the tab File Options there are some entries in the
beginning that does not have any file extensions. There I have for
example "URL: File Transfer Protocol". That must be ftp://.

However what I am missing there is something for file:///. Do you have
something for that there?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]