help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Colors and Redhat (!crystal ball)


From: William D. Colburn (aka Schlake)
Subject: Colors and Redhat (!crystal ball)
Date: Mon, 5 May 2003 12:19:22 -0600
User-agent: Mutt/1.4i

Ok, I've learned a lot about what information is important to specify,
so I'm going to splat it all out here and see if anyone can point me in
the right direction.

The problem is that weird colors appear in my emacs when I run the
command "emacs -nw -q --no-site-file" under Redhat linux.

I am used to running emacs 21.2.  At work, I am forced to use Redhat.
Redhat has emacs 21.2 installed on it.  I find the colors which appear
under Redhat to be unusable.

To see the first indication something is wrong, try the command:
  emacs -nw -q --no-site-file

I am used to, and expecting, a white screen with black text, except for
the mode bar at the bottom which will be a black background with white
text.  However: 
  21.2 on redhat will have the word "*scratch*" in a blue bar.
  21.2 on slackware will have the word "*scratch*" in a black bar.
  21.2 on Solaris will have the word "*scratch*" in a black bar.
  21.2 on Osf/1 will have the word "*scratch*" in a black bar.

The blue bar isn't unreadable, but it does annoy me.  Emacs 21.2 appears
to set that via mode-line-buffer-identification.  The default value
according to the emacs help is ("%12b").  The default value in practice
is:
  (#("%12b" 0 4 (face (:weight bold) help-echo "mouse-1: previous
  buffer, mouse-3: next buffer" local-map (keymap (header-line keymap
  (mouse-3 . mode-line-bury-buffer) (down-mouse-3 . ignore) (mouse-1
  . mode-line-unbury-buffer) (down-mouse-1 . ignore)) (mode-line keymap
  (mouse-3 . mode-line-bury-buffer) (mouse-1 . mode-line-unbury-buffer)
  (down-mouse-1 . ignore))))))

This value is the same on Redhat and Slackware.  I was able to get rid
of the blue bar with this:
 (custom-set-variables
  '(mode-line-buffer-identification '("%12b"))
 )

Putting that lisp into fixblue.el, and running the command
"emacs -nw -q --no-site-file -l ./fixblue.el" I get an all black
screen.  Yahoo!

>From there, I type 'M-x apropos' and then 'apropos-regexp'.  Now I get
the split screen and a list of things to see further help on.
21.2 on Redhat displays the words "apropos-regexp" in blue.
21.2 on Slackware displayes the words "apropos-regexp" in bold black.

Ok, lets try M-x list-faces-display:
21.2 on Redhat shows me lots of different colors and shadings.
21.2 on Slackware shows me lots of blacks and grays.

Ok, so now I look at one of the most unreadable categories in
list-faces-display: secondary-selection.

The 21.2 Redhat box has only "foreground black" and "background cyan"
(inverse-video is not on).   The 21.2 Slackware box has only "inverse
video *" (foreground and background are not on).

Perhaps Redhat changed it?  I can find out!

Now I compile my own emacs (from the source I used to make the Slackware
emacs) with --prefix=/tmp/emacs.  I then run my new emacs as so:
  /tmp/emacs/bin/emacs -nw -q --no-site-file -l ./fixblue.el

When compiled emacs from my Slackware source, the 21.2 Redhat box has
only "foreground black" and "background cyan" (inverse-video is not
on).  If I compile emacs on a Slackware box it behaves as I would
expect, and if I then copy all the executables and list files over to
the Redhat box, then the colors suddenly appear.
and activating.

The question is: WHY?  I have jumped through enough hoops to be
certain that emacs is detecting something about Redhat that causes
this to happen.  All I want to do is find out what, so I can put a
stop to it.

I have also tried setting my terminal to be xterm-mono, but that did not
help either.  The colors still appear.

--
William Colburn, "Sysprog" <address@hidden>
Computer Center, New Mexico Institute of Mining and Technology
http://www.nmt.edu/tcc/     http://www.nmt.edu/~wcolburn




reply via email to

[Prev in Thread] Current Thread [Next in Thread]