help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re[2]: Problem with clipboard


From: neverov_dg
Subject: Re[2]: Problem with clipboard
Date: Mon, 5 Mar 2007 11:55:54 +0700

>> Date: Mon, 5 Mar 2007 09:34:10 +0700
>> From: address@hidden
>> 
>> I'm running emacs on WinXP and have problems with inserting text from
>> clipboard. When I select text in MS Word or Firefox and paste it into
>> emacs it inserts symbols in latin-1 encoding, but I want him to insert
>> text in windows-1251-dos encoding.
>> 
>> When I use:
>> 
>> M-x set-next-selection-coding-system RET windows-1251-dos RET
>> 
>> and paste text all work fine, but just one time. I try to use
>> 
>> M-x set-selection-coding-system RET windows-1251-dos RET
>> 
>> but it doesn't help, text is inserted in latin-1 encoding.
>> 
>> Encoding-specific section in my .emacs:
>> 
>> (set-language-environment "Russian")
>> (define-coding-system-alias 'windows-1251 'cp1251)
>> (set-buffer-file-coding-system 'cp1251-dos)
>> (set-default-coding-systems 'cp1251-dos)
>> (set-terminal-coding-system 'windows-1251-dos)
>> (set-selection-coding-system 'cp1251-dos)
>> (prefer-coding-system 'cp1251-dos)

> What happens if you try this in "emacs -Q"?

> (On Windows XP, it's almost never the right thing to force Emacs into
> some specific encoding when working with the clipboard.)

Wow, all works fine :). emacs -Q doesn't use my .emacs, so it seems
that I have wrong configuration in it...

Now I have just:

(set-input-method "russian-computer")
(set-default-coding-systems 'windows-1251-dos)
(set-buffer-file-coding-system 'windows-1251-dos)
(prefer-coding-system 'windows-1251-dos)

in .emacs and all works fine.

Thanks!
---------------------------------
Neverov Dmitry







reply via email to

[Prev in Thread] Current Thread [Next in Thread]