help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: why I cannot run lisp in emacs?? :(


From: Giorgos Keramidas
Subject: Re: why I cannot run lisp in emacs?? :(
Date: Tue, 16 Oct 2007 23:44:53 +0300
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/23.0.50 (berkeley-unix)

On Tue, 16 Oct 2007 09:00:03 -0400, address@hidden (Joel J. Adamson) wrote:
> thinkreverse <address@hidden> writes:
> [...]
>> but the emacs report "Searching for projram: no such file or
>> directory, lisp"...... :(
>
> (setq inferior-lisp-program clisp) ; for example if your lisp program
>                                    ; is clisp

You might want to quote the value of `inferior-lisp-program':

    (setq inferior-lisp-program "clisp")

> You should change the variable "inferior-lisp-program" to your
> installation of a Common Lisp interpreter.  By default it's set to
> "lisp" --- I had to change it to "clisp."

Alternatively, you can arrange for `lisp' to be a symlink to the proper
binary.  In my case, this is:

address@hidden:/usr/local/bin> ls -l lisp
lrwxr-xr-x  1 root  wheel  - 4 Jun  4 23:39 lisp -> sbcl
address@hidden:/usr/local/bin>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]