help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: some info node manuals have no index


From: reader
Subject: Re: some info node manuals have no index
Date: Sat, 22 Dec 2007 15:24:53 -0600
User-agent: Gnus/5.110007 (No Gnus v0.7) Emacs/22.1 (gnu/linux)

Peter Dyballa <address@hidden> writes:

[...]

> Actually I think what you try is the wrong way or place to customise:
>
>       Once Info is started, the list of directories to search
>       comes from the variable `Info-directory-list'.
>       This variable `Info-default-directory-list' is used as the default
>       for initializing `Info-directory-list' when Info is started, unless
>       the environment variable INFOPATH is set.

Well that  isn't really about my problem unless it were the reason 
emacs -f info misbehaves.  But it isn't.  

I guess what you are saying here is that I must customize INFOPATH
instead of trying to do it with Info-default-directory-list.  But I
already have the correct things in INFOPATH

INFOPATH=/usr/local/info:/usr/local/share/info:/usr/local/gnus/texi:/usr/local/w3/texi:/usr/local/url/texi:/usr/local/bbdb/texinfo:/usr/local/share/emacs/site-lisp/elib-1.0/texi:$INFOPATH;export
 INFOPATH

Those old entries in site-start.el are from a time when I didn't.

According to what you've shown.. with the INFOPATH variable set, emacs
will ignore whatever I have in Info-default-directory-list. Which
doesn't matter since I have INFOPATH set as shown.

What I see here is that the standalone info browser will open gawk and
display the index of gawk manual but emacs will not.

Emacs will open the gawk manual fine, but when asked to do `i' search
I get `no index'.

Just incase they are opening different info files then doing:

info /usr/share/info/gawk.info.bz2 and inside emacs 
`C-u C-h i' /usr/share/info/gawk.info.bz2 should gaurantee its the 
same file.  But even doing it all that way emacs still reports 
`no index' when I try to use `i'; standalone info works as expected.

===================================

Eli Zaretskii <address@hidden> writes:

[...]

> This probably means your Emacs and the stand-alone Info reader get
> Info files from different places.

The test I described above should remove that as a possibility.


> Maybe your .emacs or site-start.el load other Lisp files, and those
> Lisp files modify the list of directories where Emacs searches for
> Info files?  That is, look for `load' as well, and then grep those
> additional files for `[Ii]nfo'.

  started a fresh emacs I get this in the *Messages* buffer:
  Loading w3m-wget...done
  Loading skeleton...done
  Loading regexp-opt...done
  Loading advice...done
  Loading /home/reader/.emacs-custom...done
  Loading /home/reader/.abbrev_defs...done
  Loading easymenu...done
  Loading cl-macs...done
  Loading places from /home/reader/.emacs-places...done
  For information about the GNU Project and its goals, type C-h C-p.
  Loading dired...done

grep -i info on all of those listed still shows no suspect code.


Here another piece of information.

I downloaded the latest gawk source when I first started checking into
this and after running `makeinfo gawk.texi' and loading that file
inside emacs with 
   `C-u C-h i /usr/local/src/gawk-3.1.6/doc/gawk.info'

Then emacs will respond to `i' search.

Looking at a diff of the two I see a  massive difference that
indicates the index is not present in the installed version I have.

So this all may just be the result of that not getting done in that
version. (at least not in my compiled version which is done by the
emerge tool on gentoo linux.)





reply via email to

[Prev in Thread] Current Thread [Next in Thread]