help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: change in Emacs highlighting behavior


From: Alan Mackenzie
Subject: Re: change in Emacs highlighting behavior
Date: Sun, 31 Jan 2010 15:18:32 +0000 (UTC)
User-agent: tin/1.6.2-20030910 ("Pabbay") (UNIX) (FreeBSD/4.11-RELEASE (i386))

mafaeq <address@hidden> wrote:

> Hi all,

> I recently upgraded from Ubuntu 9.04 to 9.10 and since the upgrade,
> emacs has been behaving differently. Specifically, when I left-click on
> the scroll scrollbar, it sets a mark  whenever the cursor moves,
> causing the region betw where the cursor was and where it is to become
> highlighted. This also happens if I left-click and drag along the
> scrollbar.

Sorry, can't help you here (I don't use scrollbars or the mouse), but ...

> This is the version of emacs that I am using:

> GNU Emacs 23.1.50.1 (i486-pc-linux-gnu, GTK+ Version 2.18.0)
> of 2009-09-27 on palmer, modified by Debian

This is not a released version of Emacs.  It is almost certainly a
"pretest", i.e. a beta test version, released by the Emacs development
team to those willing to test it.  A released version would have a number
like "23.1.1", where "23" is the major version, "1" the minor version,
and  "1" meaning it's the first time it's been compiled.

> I've tried removing and re-installing emacs and I've deleted my .emacs
> file and .emacs.d directory, just to make sure there was nothing there
> causing this.

You can start with "emacs -Q", which avoids loading your .emacs etc., to
check that it's Emacs at fault and not your own files.

> Oh also, when I start emacs I get the following message in the terminal

> (emacs:3741): GLib-WARNING **: g_set_prgname() called multiple times

> I don't know if that is related, but it's also new since the upgrade to
> 9.10

> Any help would be greatly appreciated!

If you are a public spirited person, you should send a bug report to
Ubuntu or even Debian.  Though, best of luck finding a person willing to
accept blame.

Otherwise, I'd recommend you to download the latest stable, released
version from this address:

    http://ftp.gnu.org/gnu/emacs/emacs-23.1.tar.bz2

(or one of the other files in the same directory (there are MS-Windows
versions there too)), and unpack, build and install it.  That version
would work properly.  With a modern DSL line and a modern PC, this whole
process would take less than an hour

-- 
Alan Mackenzie (Nuremberg, Germany).



reply via email to

[Prev in Thread] Current Thread [Next in Thread]