help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building emacs errors: libraries present


From: Eli Zaretskii
Subject: Re: Building emacs errors: libraries present
Date: Fri, 06 Feb 2015 09:50:08 +0200

> From: address@hidden (Tory S. Anderson)
> Date: Thu, 05 Feb 2015 22:27:08 -0500
> 
> $ ./configure
> ... # list omitted
> configure: error: The following required libraries were not found:
>      libpng libgif/libungif
> Maybe some development libraries/packages are missing?
> If you don't want to link with them give
>      --with-png=no --with-gif=no
> as options to configure
> 
> $ sudo yum install libpng libpng-devel
> ... # list omitted
> Package 2:libpng-1.6.6-3.fc20.x86_64 already installed and latest version
> Package 2:libpng-devel-1.6.6-3.fc20.x86_64 already installed and latest 
> version
> Nothing to do
> 
> $ whereis libpng
> libpng: /usr/lib64/libpng16.so /usr/lib64/libpng.so 
> /usr/share/man/man3/libpng.3.gz
> ==============================
> 
> Of course I've successfully built without the png libraries but I really do 
> need the png libraries for other emacs packages. What's wrong? Why is it 
> ignoring my working libpng? 

Look in config.log for clues: you should see there compiler error
messages when it tried to look for the libraries.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]