help-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gpbs & font cache problems


From: Adam Fedor
Subject: Re: gpbs & font cache problems
Date: Fri, 22 Sep 2000 08:50:53 -0600

Georgios Rizell Dimitroglou wrote:
> 
> 1) gpbs is always failing with this message when I run it (even if i run
> the bin itself):
> 
> gpbs - GNU Pasteboard server
> I don't understand ''
> --help  for help
> 

I'll have to look at that...

> 2) the font caching fails with this message
> 
> Sep 21 19:51:48 font_cacher[18174] Rename
> ('/home/grd/GNUstep/Library/Fonts/CacheiNg7lA' to
> '/home/grd/GNUstep/Library/Fonts/Cache') failed - is a Directory
> 
> and produces only an empty 'Cache' dir
> 

It's odd that this problem just started, because the bug I fixed looks
like it has been there for a while. Anyway, It should work now (the old
dir wasn't being remove before the new one
was renamed). You need to recompile the base library.

> Those where two problems I've only experienced with the later versions.
> The following problem is something I've experienced in every version:
> 
> 3) Some images are not transparent, instead the transparent area is
> coloured white. This doesn't happen on every image, but all the
> app-icons and some of the icons in GWorkspace.app. Although this error
> does not appear in for example the images on the buttons in the Save
> Panel. (applies to the xgps backend as well as the xdps one)
> 

Do a:

defaults write NSGlobalDomain GraphicCompositing YES

and try running the program again. Maybe I should turn it on by default
(or document it :-)

- 
Adam Fedor, Digital Optics            | Fudd's law of opposition: Push
address@hidden  http://www.doc.com     | something hard enough, and it 
address@hidden  http://www.gnustep.org | will fall over.
>From address@hidden Tue Sep 26 05:10:16 2000
Received: from www.brainstorm.co.uk ([212.134.110.195] helo=brainstorm.co.uk)
        by fencepost.gnu.org with esmtp (Exim 3.16 #1 (Debian))
        id 13dqkh-0001RQ-00
        for <address@hidden>; Tue, 26 Sep 2000 05:10:16 -0400
Received: (from address@hidden)
        by brainstorm.co.uk (8.9.3/8.9.3) id KAA30720
        for <address@hidden>; Tue, 26 Sep 2000 10:10:15 +0100
Received: from brainstorm.co.uk(193.114.28.41) by brainstorm.co.uk via smap 
(V2.0)
        id xma030714; Tue, 26 Sep 00 10:10:13 +0100
Received: (from address@hidden)
        by lin5.brainstorm.co.uk (8.9.3/8.9.3) id KAA06291
        for <address@hidden>; Tue, 26 Sep 2000 10:10:08 +0100
From: address@hidden
X-Authentication-Warning: lin5.brainstorm.co.uk: mail set sender to 
address@hidden using -f
Received: from lin3.brainstorm.co.uk by lin5.brainstorm.co.uk via eMail2SMS
        id smadRP2aN; Tue Sep 26 10:10:00 2000
Date: Tue, 26 Sep 2000 10:10:00 +0100 (BST)
To: address@hidden
Subject: Re: NSUserDefaults
Message-ID: <address@hidden>
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII
Sender: address@hidden
Errors-To: address@hidden
X-BeenThere: address@hidden
X-Mailman-Version: 2.0beta6
Precedence: bulk
List-Help: <mailto:address@hidden>
List-Post: <mailto:address@hidden>
List-Subscribe: <http://mail.gnu.org/mailman/listinfo/help-gnustep>, 
<mailto:address@hidden>
List-Id: Users list for the GNUstep programming environment 
<help-gnustep.gnu.org>
List-Unsubscribe: <http://mail.gnu.org/mailman/listinfo/help-gnustep>, 
<mailto:address@hidden>
List-Archive: http://mail.gnu.org/pipermail/help-gnustep/

> I`m having problems using NSUserDefaults.

> [...]

Hi Rob, as far as I can see, in your example you are only setting user
defaults in the registration domain.  (when you use registerDefaults: you
are sort-of-telling the library what defaults you want to be used if no
other defaults are found on disk.  It's sort of low-priority defaults in a
volatile domain which are used only if no 'real' defaults are set.  They
are not saved to disk because they are not real defaults.).

To set `real' defaults (the ones saved to disk) in your application, you
may try doing something like the following (I just copy an example from
Finger.app):

- (void) set: (id)sender
{
 NSUserDefaults *ud = [NSUserDefaults standardUserDefaults];

  [ud setObject: [fingerCommand stringValue] forKey: @"FingerCommand"];
  [ud setObject: [pingCommand stringValue] forKey: @"PingCommand"];
  [ud setObject: [tracerouteCommand stringValue] forKey:
        @"TracerouteCommand"];
}

<--><-->

If you perfectly knew about the registration domain and that was not your
problem, your problem could then be that in 0.6.6 applicationWillTerminate
is not correctly called.  This problem was recently fixed on CVS.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]