help-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

gnustep-base and GMP


From: Eric Heintzmann
Subject: gnustep-base and GMP
Date: Wed, 13 Oct 2004 02:33:33 +0200
User-agent: Mozilla Thunderbird 0.7.3 (X11/20040805)


   Hi,

Just a question, to seek the correct build-dependencies of the official Debian gnustep-base package:
is gnustep-base uses the mpfr library from GMP ?

   Eric

-------- Original Message --------

Hello,

The Debian packaging of GNU MP has, since version 4.1.2-2 (4 Apr 2003)
been built with --enable-mpfr.  It turns out that MPFR has
subsequently been split off into its own project and has released
several versions later than that included in GMP.
Paul Zimmermann, one of the developers of MPFR, has requested that we
stop building GMP with MPFR since the code in GMP is outdated.  That
seems like a reasonable request.  So my plan is to package MPFR from
www.mpfr.org and then about to upload a revision of GMP that doesn't
have --enable-mpfr.

If your package doesn't use the mpfr library from GMP, then nothing
will change for you.  If your package *does* use mpfr, you'll need to
change build-depends.  Also, if your package does use mpfr, could you
please let address@hidden know?
Thanks,
-Steve



_______________________________________________
pkg-GNUstep-maintainers mailing list
address@hidden
http://lists.alioth.debian.org/mailman/listinfo/pkg-gnustep-maintainers







reply via email to

[Prev in Thread] Current Thread [Next in Thread]