[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gnutls] Re: ex-serv-pgp

From: Matthias Urlichs
Subject: Re: [Help-gnutls] Re: ex-serv-pgp
Date: Mon, 12 Feb 2007 13:54:05 +0100
User-agent: Mutt/1.5.12-2006-07-14


> > >>What does 'ldd $prefix/bin/gnutls-cli' output?

For the record: Please use "ldd -r". it resolves all symbols and thus
is able to find more problems than a plan "ldd".

> =>  (0xffffe000)
> => /usr/local/lib/ (0xb7ef6000)
> => /usr/local/lib/
> (0xb7ee2000)
> => /usr/lib/ (0xb7ca1000)

Ugh. That may be a problem.

I don't know if your Linux distribution uses versioned symbols for their
libgnutls (Debian does). To find out, do

$ objdump -p /usr/lib/
$ objdump -p /usr/local/lib/

and look for the section that says "Version definitions".

If either one (or, worse, both) is not versioned, that's your problem.

Otherwise (i.e. if they're both versioned), make sure that you didn't
compile against your local gnutls installation but linked against the
public one (or vice versa).

Matthias Urlichs   |   {M:U} IT Design @   |  address@hidden
Disclaimer: The quote was selected randomly. Really. |
 - -
There was an old voyeur named Zeke,
Who liked to hide in the closet and peek,
    Then jump out with loud cries
    of "Aha!" and "Surprise!"
And point out your flaws in technique.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]