[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: configure: WARNING: UMFPACK not found (although installed)

From: norberthauser04
Subject: Re: configure: WARNING: UMFPACK not found (although installed)
Date: Sun, 19 Nov 2006 02:17:14 +0100

> -----Ursprüngliche Nachricht-----
> Von: "John W. Eaton" <address@hidden>
> Gesendet: 19.11.06 00:27:25
> An: Norbert Hauser <address@hidden>
> CC: address@hidden
> Betreff: configure: WARNING: UMFPACK not found (although installed)

> On 19-Nov-2006, Norbert Hauser wrote:
> | I am desperately trying to compile octave-2.9.6.
> Why not 2.9.9?  If you are using 2.9.x, you might as well use the
> latest one.

I took 2.9.6 since the latest octave-forge is for this octave version. Will it 
also work for 2.9.9?

One of the reasons that I use the 2.9 branch is that I haven't been successful 
with the octave-forge installation for 2.1.72, and 2.9 already includes some 
sparse functionality (which I need) from octave-forge. Is there some 
step-by-step guide howto install any octave with the compatible actave-forge? 
All combinations I tried ended with some compilation errors, and I wonder how 
these versions made it into the release.

> | I have installed SuiteSparse including UMFPACK and metis.
> | I have set
> |  export LDFLAGS=-L $HOME/tmp/SuiteSparse/UMFPACK/Lib/
> |  export CFLAGS=-I $HOME/tmp/SuiteSparse/UMFPACK/Include/
> | 
> | When running
> | cd $HOME/tmp/octave-2.9.6
> | ./configure
> | somewhere near the end of config.log I read the following error messages 
> (see below). 
> | What can I do against "WARNING: UMFPACK not found."? Do I have to set 
> --with-umfpack=yes (or =some lib)?
> | 
> | Regards,
> | Norbert
> | 
> | Here is part of the config.log:
> | [...]
> | Octave is now configured for i686-pc-linux-gnu
> Run configure like this:
>   configure CPPFLAGS="-I$HOME/tmp/SuiteSparse/UMFPACK/Include" \
>             LDFLAGS="-L$HOME/tmp/SuiteSparse/UMFPACK/Lib" \
>             ... other otptions ...

I tried this. Same error:
configure: WARNING: UMFPACK not found.  This will result in some lack of 
functio                  nality for sparse matrices.
configure: WARNING: COLAMD not found. This will result in some lack of 
functiona                  lity for sparse matrices.

I'll use 2.9.9 and try again.
Is there another download location than Quite often I can't access 
that page because of timeout errors.

"Ein Herz für Kinder" - Ihre Spende hilft! Aktion:
Unser Dankeschön: Ihr Name auf dem Segel der 1. deutschen America's Cup-Yacht!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]