[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: make check: src/DLD-FUNCTIONS/ ..............................

Subject: RE: make check: src/DLD-FUNCTIONS/ .............................. ** On entry to DLASCL parameter number 4 had an illegal value
Date: Thu, 2 Sep 2010 15:34:41 -0500

BLAS_LIBS is set correctly, but in configure it does:

cat >conftest.$ac_ext <<_ACEOF

This seems to be ignoring the BLAS_LIBS variable, although configure is still a pretty mysterious file to me.

I tried using...
./configure ... --with-blas='-Wl,--start-group -lmkl_intel -lmkl_intel_thread -lmkl_core -Wl,--end-group -liomp5 -lpthread' --with-lapack='-Wl,--start-group -lmkl_intel -lmkl_intel_thread -lmkl_core -Wl,--end-group -liomp5 -lpthread -lmkl_lapack' ...  LIBS='-lmetis' see if including all the BLAS libs in the --with-lapack= switch and it worked.  I guess using LIBS= would probably work just as well, but it would be a good idea to reference BLAS_LIBS in the configure script in the future since that's the more "correct" place to declare those libraries.

> Date: Thu, 2 Sep 2010 21:24:44 +0200
> Subject: Re: make check: src/DLD-FUNCTIONS/ .............................. ** On entry to DLASCL parameter number 4 had an illegal value
> From: address@hidden
> To: address@hidden
> CC: address@hidden
> On Thu, Sep 2, 2010 at 8:25 PM, RUSS BRENNAN <address@hidden> wrote:
> > I've been poking around this issue and I'm not convinced that I have the
> > configure line correct, or perhaps the configure script is misbehaving.
> >
> > I use the following line, as of now:
> >
> > ./configure --enable-shared --disable-static --with-blas='-Wl,--start-group
> > -lmkl_intel -lmkl_intel_thread -lmkl_core -Wl,--end-group -liomp5 -lpthread’
> >  --with-lapack='-lmkl_lapack' --disable-extra-warning-flags F77=ifort
> > FFLAGS="-O3 -xW" CC=icc CFLAGS="-O2 –gcc-version=410 -xW -mieee-fp
> > -I/usr/local/include/" CXX=icpc CXXFLAGS="-w -O2 –gcc-version=4xx -xW
> > -mieee-fp -I/usr/local/include/" CPP="icc -E"
> > CPPFLAGS="-I/usr/local/include/" CXXPP="icpc -E" LDFLAGS="-L/usr/local/lib/
> > -L$MKLPATH" LIBS="-lmetis"
> >
> > This results in configure not finding ARPACK because it thinks it has
> > undefined symbols.
> >
> > In order to resolve this, I have to do LIBS="-Wl,--start-group -lmkl_intel
> > -lmkl_intel_thread -lmkl_core -Wl,--end-group -liomp5 -lpthread -lmetis",
> > but I had already specified that whole mkl mess with the --with-blas=
> > switch.  Shouldn't configure know to link the BLAS stuff in when doing the
> > ARPACK check?
> >
> >
> It should. Does it work if you set BLAS_LIBS rather than use
> --with-blas and --with-lapack? What's the value of BLAS_LIBS in
> Makefile? In any case, if you're compiling a shared library for
> ARPACK, it won't hurt if you make lapack its dynamic dependency.
> hth
> --
> RNDr. Jaroslav Hajek, PhD
> computing expert & GNU Octave developer
> Aeronautical Research and Test Institute (VZLU)
> Prague, Czech Republic
> url:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]