[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Contribution to the Hurd on L4

From: Matthieu Lemerre
Subject: Re: Contribution to the Hurd on L4
Date: Thu, 06 Jan 2005 21:22:15 +0100
User-agent: Gnus/5.1007 (Gnus v5.10.7) Emacs/21.3 (gnu/linux)

Marcus Brinkmann <address@hidden> writes:

> At Thu, 30 Dec 2004 19:51:17 +0100,
> Matthieu Lemerre <address@hidden> wrote:
>> Neither task nor deva was started for me. I recompiled a l4 kernel and
>> it worked. (Maybe I was using the old patch for pistachio 0.2)
> If your grub config is right, and deva is not started, then you should
> look at using the latest pistachio as required in the README.  deva
> does have a cheesy kbd driver which echoes kbd input, and ESC will
> trigger int $3 to get you into the debugger if you enabled the trap in
> the configuration of pistachio.  That should give you a hint if it is
> running.

I was in fact meaning that I managed to make it work.

I looked at it, and I was wondering when work on the device driver
framework could begin? I think it would require some work and I would
be happy to contribute :) (but I would also be happy to contribute to
any other thing)

>> It works well when I omit the   l4_msg_append_simple_string_item (msg, 
>> string_item);
>> line, but fail with the e field of the IPC error code set to 4
>> otherwise. After a while of hard debugging session (I have to reboot,
>> bochs won't run on my old PC), I decided to flood the mailing list a little 
>> more :)
> By now you found problems in libl4, so I didn't review your code.  You
> could try qemu btw, which works fine for me when I run it within a gdb
> session (don't ask).

It works for me without using gdb, but I had to put some special arguments :

   qemu -user-net -std-vga -fda image -boot a
(using a modified grub floppy disk image)

It helped me greatly to debug the strings part of libl4.
>> I have some questions regarding the libl4 interface:
>> -How to create a new string item with the GNU interface? The
>>  _L4_string_item function does not have a GNU "name".
> Yes, it is missing.  Want to send in a patch?

Of course :), I will include it in my next patch.

>> -What is the bug in _L4_msg_get_string_item?
> Wish I could remember with certainty, but it may very well be that I
> think that it possibly violates the strict aliasing rules of ISO C99.
> Ie, the casts of &msg[] pointers to the string type has to be replaced
> with explicit assignments to msg[] from .raw parts of the string item,
> as I did for the other similar functions at some time.
> I don't know if you are familiar with the strict aliasing rules, if
> the above sounds like gibberish to you, let me know and I will
> elaborate.
Please do, I tried to find on google but I didn't find. I would be
pleased to know.

>> But maybe I should post my messages to help-hurd? I don't want to
>> flood the mailing list with uninterresting questions.
> No, please keep going, excellent stuff.

Thank you very much :)

> Thanks, Marcus


reply via email to

[Prev in Thread] Current Thread [Next in Thread]