[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Licensing dependencies

From: Joseph Wakeling
Subject: Re: Licensing dependencies
Date: Sun, 20 Sep 2009 16:23:31 +0200
User-agent: Thunderbird (X11/20090817)

Reinhold Kainhofer wrote:
> Am Sonntag, 20. September 2009 13:46:32 schrieb Joseph Wakeling:
>> It looks like the problems are FreeType (GPLv2 only or GPL-incompatible
>> permissive license, so blocks upgrade); 
> The FTL is GPLv2-incompatible, but according to the FSF, it's GPLv3-
> compatible... See 
> No blocker here.

Oh, great.  Missed that when reading the compatible license list.

>> Guile (future versions will be
>> LGPLv3+, so GPLv2-only-incompatible); and potentially Pango (if it
>> upgrades to LGPLv3+).
>> None are a present, active problem but all are clear risks.
> Yes, that's the only possible license issue in the future that I can see. 
> Everything else appears okay...

So, the upshot is that, while not an absolute necessity, it would be
highly convenient to gain GPLv3 compatibility.

If there are no objections I will continue to track contributors and ask
for their licensing preferences -- specifically, what is the most
permissive license they are willing to permit (i.e. GPLv2/3, GPLv2+,
BSD-style, etc.) -- and record in the publicly-viewable Google Doc
mentioned previously.

Best wishes,

    -- Joe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]