[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem installing build requirements [Mac OS X 10.4.11]

From: Graham Percival
Subject: Re: problem installing build requirements [Mac OS X 10.4.11]
Date: Thu, 12 Nov 2009 03:03:09 +0000
User-agent: Mutt/1.5.18 (2008-05-17)

On Wed, Nov 11, 2009 at 09:35:35PM -0500, Kieren MacMillan wrote:
> Hi Graham,
>> - why modify configure.make ?!  that shouldn't be necessary.
> I tried make, and had problems — specifically,
> mkdir -p ./out
> echo 2.13.8 > out/VERSION
> /bin/sh: line 1: out/VERSION: Permission denied
> make: *** [out/VERSION] Error 1

I'll bet you a double-double and 20 timbits[1] that this is
because of "sudo make", or running sudo at some point when
downloading the source?  Once you do "sudo make clean; sudo make
distclean", all the out/ and out-www/ directories should be gone,
and you shouldn't have this problem any more if you run plain

[1]  I miss timbits.  :(

> There, I found the "Compiling on MacOS X" instructions which told me to 
> modify configure.make, etc.

Hmm, ok.  Those instructions look fine.  I forgot they were there.
I'm slightly supicious that they might be 10.5-specific, since I
never touched config.make when I had osx 10.4... but then again, I
never tried to build lilypond itself; I only compiled the docs.

- Graham

reply via email to

[Prev in Thread] Current Thread [Next in Thread]