[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Update program requirements.

From: Patrick McCarty
Subject: Re: [PATCH] Update program requirements.
Date: Thu, 21 Jan 2010 07:59:17 -0800

On Wed, Jan 20, 2010 at 10:44 PM, Mark Polesky <address@hidden> wrote:
> Patrick McCarty wrote:
>>> * New compiling requirements:
>>>  -  GCC 4.0
>> Are you sure this is required?
>> OpenBSD's gcc 3.3.5 apparently works okay with this patch:
> I think Graham was suggesting that by updating the requirement,
> we're not saying that older versions will fail, but rather that we
> are no longer officially supporting them.  GCC 3.3.5 is from 2004
> ( and
> there have been six major releases since then.  GCC 4.0 came in
> 2005, so it's not such a huge leap.

I don't know what LilyPond's previous policy has been with regard to this.

But it seems that by specifying a *minimum* version in configure, we
are suggesting that earlier versions *will* fail (depending on the use

> Besides, shouldn't GCC 3.3 users be upgrading anyway?


> Because of this, I wouldn't mind moving the requirement up to
> 4.2.4, but there may be some issues I'm not aware of.  Let me
> know if there are.

GUB uses 4.1.2 to compile LilyPond for certain platforms:

> Otherwise, what do you think?

I think we need more feedback from others regarding GCC before taking
action.  The Guile and Ghostscript minimum versions are fine with me.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]