[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: offset not working

From: Kris Shaffer
Subject: Re: offset not working
Date: Tue, 23 Aug 2005 08:55:28 -0400
User-agent: Opera M2/8.01 (MacPPC, build 2092)

Is ly/ online somewhere? I can't find a lilypond-doc package for Mac OS X, and I don't have any lilypond stuff in /usr/share/.

In the meantime, I tried \override MultiMeasureRestText #'no-spacing-rods = ##f in place of \fatText, but it did not work. I also found in the program reference online that, though TextScript takes #'no-spacing-rods, MultiMeasureRestText does not. Did I miss anything, or would this feature need to be added?


On Mon, 22 Aug 2005 23:25:17 -0400, Graham Percival <address@hidden> wrote:

On 22-Aug-05, at 6:15 PM, Kris Shaffer wrote:

One more question on this issue:
The commands \fatText and \emptyText have no effect on either

        s1*0^\markup {whatever}


        R1*4^\markup {whatever}

How can I automatically apply the width of the markup string to the width of the multi-rest bar?

Take a look in ly/ to find out what \fatText does, then change
the TextScript to MultiMeasureRestText.

fatText = \override TextScript  #'no-spacing-rods = ##f
emptyText = \override TextScript  #'no-spacing-rods = ##t

I've added the following to the manual:

Warning!  This text is created by @code{MultiMeasureRestText}, not

\override TextScript #'padding = #5
\override MultiMeasureRestText #'padding = #5

Kris Shaffer
graduate student in music theory, Yale University

reply via email to

[Prev in Thread] Current Thread [Next in Thread]