[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Unable to run lilypond through web server, php etc

From: Maurits Lamers
Subject: Unable to run lilypond through web server, php etc
Date: Sun, 30 Jul 2006 06:02:48 +0000 (UTC)
User-agent: Loom/3.14 (

Hi all,

I am trying to extend a latexrender plugin for dokuwiki 
( to also be able to generate 
notation fragments using lilypond 2.8.

I have been struggling for a couple of days now to get 
lilypond running through the web server and it fails 
again and again and again.

When run as user from a command line, there is no
problem. Lilypond generates without problems.
No matter what user, even the apache user 
(by running sudo -u apache as root).

But every way that I have tried to let lilypond run by
the webserver fails. When run using php, lilypond-book
runs, but as soon as lilypond is run to generate the eps
 files, it fails with Child terminated by signal 6. 
Adding --safe to the lilypond options does nothing. 
Jailing does not work either.

Running latex...Dissecting...
Writing snippets...
Running lilypond...command failed: lilypond -b eps 
-I  '/tmp' lily-1405697360
Child was terminated by signal 6

I created a shell script to run it directly from php, 
and this generates the same error. I made the shell script 
into a suexec script and call it using executing wget or 
directly myself using a browser, same problem....

When the -V option is added to the --process= option:
[error]  Initializing FontConfig...
[error]  command failed: lilypond --safe -b eps -V 
-I  '/tmp' lily-136795500
[error]  Child was terminated by signal 6

Even when I call lilypond again in the script after 
lilypond-book crashes, it fails:
lilyrender.cgi: line 32:  3554 Aborted 
lilypond -V --safe -b eps -I '/tmp' 
-I '/tmp/lilypond-out' lily-*.ly

Anyone an idea?

Thanks in advance!



reply via email to

[Prev in Thread] Current Thread [Next in Thread]