[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Lilypond + LaTex (on Mac)

From: Peter O'Doherty
Subject: Re: Lilypond + LaTex (on Mac)
Date: Sun, 17 Sep 2006 10:10:32 +0200

I'm not quite sure what I did wrong but I tried this a few times and it still doesn't want to work. I am able to run steps 1 - 4 but at step 5, the line already reads "export PATH=$PATH:/Applications/" so it doesn't seem to make sense to add ":/Applications/ Contents/Resources/bin" as stated in step 5.
What am I doing wrong?

Thanks again,

Thanks, Graham. So here's what Peter (and I) need to do, assuming that
you moved the LilyPond app off your desktop and into the Applications

1) Open a new terminal window.

2) Type:

3) In the program that opens, type <Ctrl>R. Type

and hit <Enter>.

You'll probably get a message: ".profile" not found, which is fine. If
that's what happened, skip to step (6)

4) Look in the file that loaded and see if it has a line that begins:
export PATH=

If it doesn't, then go on to step (6).

5) Move the cursor to the end of line that begins:

export PATH=

and add this to the end of it:


Make sure to hit <Return> at the end of that line, and make sure not
to add any spaces before the colon, which has to be there. My line
looks like this:

export PATH=/opt/local/bin:/opt/local/sbin:/Applications/

(It's all on one line, with a space between export and PATH, like
this: "export PATH"

Upper and lower case makes a difference!

Now skip to step (7)

6) Type:
export PATH=$PATH:/Applications/

7) Type <Ctrl>O (that's a letter o, not a numeral 0). When it prompts
with "File to save", type:

and hit <Enter>. If it asks if it's OK to overwrite, you should be
able to say "Yes" safely if you followed the instructions above. Note
that I am NOT responsible if, instead of doing anything useful, your
computer does something catastrophic, or just quits working the way
you want it to. It shouldn't happen, but I make no guarantees.

8) Type <Ctrl>X, which closes the editor.

9) Type:

and hit <Enter>

10) Close the terminal window.

11) Open a new terminal window and see if lilypond-book works now.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]