[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Dumb Emacs lilypond-mode question

From: Arjan Bos
Subject: Re: Dumb Emacs lilypond-mode question
Date: Fri, 5 Mar 2010 19:53:57 +0100

On 28 feb 2010, at 06:46, Tim McNamara wrote:

> I've had lilypond-mode working in Emacs for a year now, using Carbon Emacs on 
> Mac OS X 10.4.  Works great, kuds to whomever wrote the mode.  I just built 
> the latest Emacs 23.1 to give it a try; it initially didn't work with 
> Lilypond at all until I remembered I had to add the lilypond-mode .el files 
> to site-lisp inside  So, did that and lilypond-mode is 
> automatically loaded when I open a .ly file.  Yay.  Everything looks fine, 
> syntax coloring works, etc.
> However, I can't compile.  C-c C-l results in "Compilation exited abnormally 
> with code 127" (paraphrasing from memory here; there's also a /bin/bash 
> complaint too).  Interestingly C-c C-s launches the designated PDF viewer 
> (Preview) just fine, if I open a .ly file that has already been compiled and 
> has a rendered PDF already.
> This is not a new issue, when I tried to set up Carbon Emacs about a year ago 
> I had the same problem... but I can't remember the fix and hence that is the 
> "dumb" part of my question. I haven't been able to track the fix down in the 
> archives of the lilypond-user list, which is where I got the fix last year 
> IIRC.  Can anybody point me in the right direction?


You can also customize Lilypond `M-x customize-group Lilypond' and change the 
`Lilypond lilypond Command' to something on your GUI path.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]