[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: incorrect displaying of Arabic text

From: James Bailey
Subject: Re: incorrect displaying of Arabic text
Date: Sat, 29 Jan 2011 20:14:02 +0100

On Jan 29, 2011, at 7:10 PM, Carl Sorensen wrote:

> On 1/29/11 7:45 AM, "James Samir Ismail" <address@hidden> wrote:
>>> The first thing to do is to run the specified command from a terminal
>>> window:
>>> lilypond -dshow-available-fonts x
>>> You said before that "it didn't work".  We don't know what that means, so we
>>> can't help you.
>> This is what it means:
>> Zamzam:bin samir$ ./lilypond -dshow-available-fonts x
>> GNU LilyPond 2.12.3
>> warning: not relocating, no 2.12.3/ or current/ found under
>> /Applications/
>> ERROR: In procedure primitive-load-path:
>> ERROR: Unable to find file "lily.scm" in load path
>> Zamzam:bin samir$
>>> You should execute the command, and then report on the results.  Preferably
>>> with a copy of the output that went to the terminal window.
>>> Once we get that, we can start to troubleshoot the problem you're having.
>>> HTH,
>>> Car
>> Is there a different way I should be executing this? I'm runing MacOS 10.6,
>> Lilypond v2.12.3.
> I don't use the installed version of LilyPond on my Mac, because I wanted to
> be able to build it.  So my advice may be somewhat suspect.
> Have you tried running lilypond without the ./ in front of it?  In other
> operating systems, lilypond installs with a path variable that allows it to
> run from a terminal window from any directory.  I don't know if it does or
> not on OSX.
> However, I think that you have probably identified the problem correctly,
> that is, the missing files in the Pango installation.
> Thanks,
> Carl

To clarify, if I run this command from the folder containing the lilypond 
binary (~/Applications/, I get the 
abovementioned error. I get this error regarldess of using latest git, 
distributed development, or latest stable.

If I run this command from my home user directory (~/), I get:
GNU LilyPond 2.12.3
warning: no such internal option: show-available-fonts-x

With the appropriate version changes depending on which version I call.

If I run lilypond -dshow-available-fonts, I get a list of all the fonts 
lilypond knows about. Additionally, lilypond -dhelp only lists 
show-available-fonts (#f) and no show-available-fonts-x option. I suspect that 
there are two problems here. One, asking lilypond for this option for some 
reason completely bypasses the $PATH environment variable. And two, perhaps the 
show-available-fonts-x option only exists on linux computers, not macintosh.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]