[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Ltib] how to change the version of software being built by LTIB?

From: Robert P. J. Day
Subject: [Ltib] how to change the version of software being built by LTIB?
Date: Sun, 28 Dec 2008 10:59:00 -0500 (EST)
User-agent: Alpine 2.00 (LFD 1167 2008-08-23)

  i ran across something a little curious when trying to change the
version of a software package in my current ltib build.  i used the
"pkg_map" file and changed the version of openssl i wanted.  during
the build, when that step was encountered, you could read:

Processing: openssl-0.9.7g
..... openssl-0.9.8a-1.m68k.rpm

  as in, the previous version of openssl was 0.9.8a and that's the rpm
file that already existed, but when i tried to change the version
(just as a test), the "Processing" line seemed to recognize the
change it read from pkg_map, but that didn't replace the rpm file that
was already built.

  i literally had to delete the existing openssl rpm file for a new
one to be created.  should i have expected this?  could this be an
artifact based on the fact that we're using an older version of ltib


Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry:
    Have classroom, will lecture.                          Waterloo, Ontario, CANADA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]