[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ltib] how to change the version of software being built by LTIB?

From: Robert P. J. Day
Subject: Re: [Ltib] how to change the version of software being built by LTIB?
Date: Tue, 30 Dec 2008 06:51:15 -0500 (EST)
User-agent: Alpine 2.00 (LFD 1167 2008-08-23)

On Tue, 30 Dec 2008, Stuart Hughes wrote:

> Hi Robert,
> This is not expected.  If it is reproducible in the latest Savannah CVS
> then it's a bug that would need investigation.
> Regards, Stuart
> On Sun, 2008-12-28 at 10:59 -0500, Robert P. J. Day wrote:
> >   i ran across something a little curious when trying to change the
> > version of a software package in my current ltib build.  i used the
> > "pkg_map" file and changed the version of openssl i wanted.  during
> > the build, when that step was encountered, you could read:
> >
> > ...
> > Processing: openssl-0.9.7g
> > ...
> > ..... openssl-0.9.8a-1.m68k.rpm
> >
> >   as in, the previous version of openssl was 0.9.8a and that's the rpm
> > file that already existed, but when i tried to change the version
> > (just as a test), the "Processing" line seemed to recognize the
> > change it read from pkg_map, but that didn't replace the rpm file that
> > was already built.
> >
> >   i literally had to delete the existing openssl rpm file for a new
> > one to be created.  should i have expected this?  could this be an
> > artifact based on the fact that we're using an older version of ltib
> > here?
> >
> > rday

  sadly, i can't test it under the latest LTIB as we're still stuck
with using an older version here.  it should be trivially easy for
anyone else to try it and see if that behaviour still occurs.  if not,
then i'll just write it off as a historical artifact of an older LTIB.


Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry:
    Have classroom, will lecture.                          Waterloo, Ontario, CANADA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]