[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ltib] Fwd: ltib installation problem

From: Peter Barada
Subject: Re: [Ltib] Fwd: ltib installation problem
Date: Tue, 06 Mar 2012 13:27:07 -0500
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20120216 Lightning/1.0b2 Thunderbird/3.1.19

On 03/06/2012 11:55 AM, Douglas Peterson wrote:

This has always bugged me, but I’ve never bothered to ask: If the purpose of adding this line is to execute rpm commands as root without a password, why do I have to enter a password (almost) every time I run ./ltib?

You shouldn't have to.

1) What is it asking you sudo to do?
2) Which version if Linux are you running?
3) What does you sudoers file look like(i.e. what did you add)?  I have:

peter  ALL = NOPASSWD:    /usr/bin/rpm, /opt/ltib/usr/bin/rpm

At the absolute end of /etc/sudoers.  If you use a Cmd_Alias instead, I've run across a few Linux versions where that didn't work, it would always ask for a password...




From: address@hidden [mailto:address@hidden] On Behalf Of Peter Barada
Sent: Tuesday, March 06, 2012 8:50 AM
To: address@hidden
Subject: Re: [Ltib] Fwd: ltib installation problem


On 03/06/2012 11:26 AM, Giuseppe wrote:

Hi all,
i'm trying to install LTIB for configure my kernel for imx53 QSB board.
I want install ubuntu with driver for SIERRA SL8092 modem HSPA.
I'm newbie. How i can do?
i have this error when i write./ltib:

I ran the command: sudo -S -l which returned:

Matching Defaults entries for giuseppe on this host:

User giuseppe may run the following commands on this host:
    (root) NOPASSWD: /usr/bin/rpm, (root) /opt/freescale/ltib/usr/bin/rpm
    (ALL) ALL

This means you don't have sudo permission to execute rpm commands as root
without a password.  This is needed for this build script to operate correctly.

To configure this, as root using the command "/usr/sbin/visudo",
and add the following line in the User privilege section:

giuseppe ALL = NOPASSWD: /usr/bin/rpm, /opt/ltib/usr/bin/rpm

Giuseppe, you need to modify /etc/sudoers (run "sudo /usr/sbin/visudo") to allow you to run "/opt/ltib/user/bin/rpm" - it shows you can run "/opt/freescale/ltib/user/bin/rpm".  Make that change and this error should go away...

Peter Barada

Peter Barada

reply via email to

[Prev in Thread] Current Thread [Next in Thread]