[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ltib] Fwd: ltib installation problem

From: Douglas Peterson
Subject: Re: [Ltib] Fwd: ltib installation problem
Date: Tue, 6 Mar 2012 18:52:53 +0000

Below is my sudoers file. It is Ubuntu 11.04. If my sudoers file was not 
correct, I would get the same error that Giuseppe did (I recall that from my 
setup experience).

The prompt I get when I run LTIB is (note that 'build' is the user name on this 
[sudo] password for build:

If I have recently entered the password, I won't get prompted. The point in the 
build process that I get prompted seems random. It generally happens during the 
merge step, but can be earlier or later.

This sudo behavior is "normal". It works this way when I sudo anything, like 
"sudo rm -r rootfs" which I do fairly often.


# This file MUST be edited with the 'visudo' command as root.
# Please consider adding local content in /etc/sudoers.d/ instead of
# directly modifying this file.
# See the man page for details on how to write a sudoers file.
Defaults        env_reset

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root    ALL=(ALL:ALL) ALL
build ALL = NOPASSWD: /usr/bin/rpm, /opt/ltib/usr/bin/rpm

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

# Allow members of group sudo to execute any command
%sudo   ALL=(ALL:ALL) ALL

#includedir /etc/sudoers.d

From: Peter Barada [mailto:address@hidden 
Sent: Tuesday, March 06, 2012 10:27 AM
To: Douglas Peterson
Cc: address@hidden
Subject: Re: [Ltib] Fwd: ltib installation problem

On 03/06/2012 11:55 AM, Douglas Peterson wrote: 
This has always bugged me, but I've never bothered to ask: If the purpose of 
adding this line is to execute rpm commands as root without a password, why do 
I have to enter a password (almost) every time I run ./ltib?
You shouldn't have to.

1) What is it asking you sudo to do?
2) Which version if Linux are you running?
3) What does you sudoers file look like(i.e. what did you add)?  I have:

peter  ALL = NOPASSWD:    /usr/bin/rpm, /opt/ltib/usr/bin/rpm

At the absolute end of /etc/sudoers.  If you use a Cmd_Alias instead, I've run 
across a few Linux versions where that didn't work, it would always ask for a 

From: address@hidden [mailto:address@hidden On Behalf Of Peter Barada
Sent: Tuesday, March 06, 2012 8:50 AM
To: address@hidden
Subject: Re: [Ltib] Fwd: ltib installation problem
On 03/06/2012 11:26 AM, Giuseppe wrote: 
Hi all,
i'm trying to install LTIB for configure my kernel for imx53 QSB board.
I want install ubuntu with driver for SIERRA SL8092 modem HSPA.
I'm newbie. How i can do?
i have this error when i write./ltib:

I ran the command: sudo -S -l which returned:

Matching Defaults entries for giuseppe on this host:

User giuseppe may run the following commands on this host:
    (root) NOPASSWD: /usr/bin/rpm, (root) /opt/freescale/ltib/usr/bin/rpm
    (ALL) ALL

This means you don't have sudo permission to execute rpm commands as root
without a password.  This is needed for this build script to operate correctly.

To configure this, as root using the command "/usr/sbin/visudo",
and add the following line in the User privilege section:

giuseppe ALL = NOPASSWD: /usr/bin/rpm, /opt/ltib/usr/bin/rpm
Giuseppe, you need to modify /etc/sudoers (run "sudo /usr/sbin/visudo") to 
allow you to run "/opt/ltib/user/bin/rpm" - it shows you can run 
"/opt/freescale/ltib/user/bin/rpm".  Make that change and this error should go 

Peter Barada

Peter Barada

reply via email to

[Prev in Thread] Current Thread [Next in Thread]