[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LYNX-DEV Anyone using Solaris 2.5.1 out there?

From: Drazen Kacar
Subject: Re: LYNX-DEV Anyone using Solaris 2.5.1 out there?
Date: Wed, 29 Jan 1997 22:57:50 +0100 (MET)

Robert Bonomi wrote:

> Solaris 2.x does not include a 'bundled' compiler, Thomas is correct.
> Sun does _sell_ a C compiler for Solaris 2.x. (for that 'small minority'
> of their customers that -really- need one. :)    The price for the "Sun C"
> compiler is moderately outrageous, and per-user licensed.

Depends. I have it per domain licenced. And the price was not outrageoos,
I think. But if you want to buy a compiler, I'd recomend Apogee C compiler
which outperforms anything else. They claim that even Sun uses it.
Unfortunately, I don't have it. I suppose that's because Sun's compiler
was much cheaper. :)

> Thus, 'gcc'
> is far-and-away the 'most common' compiler for the Solaris 2.x environment.
> Therefore, the necessity of the 'unbundled' description, when referring
> specifically to the compiler sold by Sun for Solaris 2.x.

Gcc has bugs. You never know what you'll get when compiling multithreaded
programs with optimization. If you turn optimization off, the code will
work, but unbelievaby slow.

They work 24 hours a day and 256 days a year  --  address@hidden

; To UNSUBSCRIBE:  Send a mail message to address@hidden
;                  with "unsubscribe lynx-dev" (without the
;                  quotation marks) on a line by itself.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]