[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LYNX-DEV Can't compile 2.7.2 on Linux Slackware

From: T.E.Dickey
Subject: Re: LYNX-DEV Can't compile 2.7.2 on Linux Slackware
Date: Sun, 1 Mar 1998 19:47:12 -0500 (EST)

> I am having problems getting Lynx 2.7.2 to compile on my Linux Slackware
> system. (I tried another Slackware box, and got the same error, too)
> Here's what I get when I type make linux:
It depends on what you have installed - I believe 2.7.2 has not been tested
recently on Linux.  I just checked, scrollok is a macro in the BSD curses
implementation.  (In ncurses, and probably Solaris which Fote did
test-build, it would be both a macro and a function).

So probably the fix for 2.7.2 is to add an include for LYCurses.h to the
modules that are referencing scrollok, and clearok.

(The 2.8pre development version builds correctly on all of the
configurations that I have available - it would be nice if someone were to
try building it for VMS so that we can resolve any build problems before
2.8 is released).
> Linking and creating Lynx executable
> -I../WWW/Library/Implementation -DDIRED_SUPPORT  -DOK_TAR -DOK_ZIP -DOK_GZIP 
> LYShowInfo.o LYEdit.o LYStrings.o LYMail.o HTAlert.o GridText.o LYGetFile.o 
> LYMain.o LYMainLoop.o LYCurses.o LYBookmark.o LYUtils.o LYOptions.o 
> LYReadCFG.o LYSearch.o LYHistory.o LYForms.o LYPrint.o LYrcFile.o 
> LYDownload.o LYNews.o LYKeymap.o HTML.o HTFWriter.o HTInit.o DefaultStyle.o 
> LYLocal.o LYUpload.o LYLeaks.o LYexit.o LYJump.o LYList.o LYCgi.o 
> LYTraversal.o LYEditmap.o LYCharSets.o LYCharUtils.o LYMap.o LYCookie.o 
> ../WWW/Library/unix/libwww.a  -lcurses -ltermcap  
> LYMail.o: In function `reply_by_mail':
> LYMail.o(.text+0xf04): undefined reference to `scrollok'

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]