[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lynx-dev UnixWare 2.1.2 pre-compiled Binary

From: dickey
Subject: Re: lynx-dev UnixWare 2.1.2 pre-compiled Binary
Date: Sun, 13 Dec 1998 07:38:32 -0500 (EST)

> Hey, Tom.  
> I've been working on the 2-8-1 source all night so far and when I first 
> configured autoconf, it could not find the slang libs. When I updated my 
> version of Slang to 2.2.1 (I believe), autoconf worked with no problems.  
> I then tried to Make and here's the interesting error I get...(I took 
> this screen grab after the initial error, which is why it states that 
> "libwww.a is up to date"). 

libwww.a, btw, doesn't use the curses/ncurses/slang interfaces - so that's ok.
> $ make 
> UX:make: WARNING: No suffix list. 
>         cd WWW/Library/unix && make CC="cc" \ 
>                 LY_CFLAGS="" \ 
>                 CPPFLAGS="/home/titus/bin/include" \ 

                  CPPFLAGS="-I/home/titus/bin/include" \ 
( get more sleep :-)

>         cc -DHAVE_CONFIG_H /home/titus/bin/include  -I.  -I..  
> -Ichrtrans  -I./chrtrans  -I..  -I../src  
> -I../WWW/Library/Implementation    -c ./LYClean.c 
> UX:acomp: ERROR: "./LYCurses.h", line 33: cannot find include file: 
> <slang.h> 
> *** Error code 1 (bu21) 
> UX:make: ERROR: fatal error. 
> It's quite strange why "LYCurses.h" can not find the slang.h library 
> when the CPPFLAGS environment has it linked with no problem. I also have 

LIBS is the variable that makes it find the library, for linking.

> all 3 Slang libs backed up in another directory and when I link the 
> Makefile to it, I get the same error as well.  
> Any suggestions? 

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]