[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

weird logs showing up

From: alex black
Subject: weird logs showing up
Date: Fri, 10 Mar 2006 13:16:59 -0800

hey all,

I've got a simple check happening on a PHP URL:

in /var/log/syslog:
Mar 10 14:06:08 lamp monit[18769]: HTTP error: cannot parse HTTP status in response: <!-- UNKNOWN sec -->HTTP/1.1 302 Found

in my monitrc include:
    if failed url
        timeout 3 seconds
        then restart

curl --include|head shows:

HTTP/1.1 200 OK
Date: Fri, 10 Mar 2006 21:12:27 GMT
Server: Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-16 mod_ssl/2.0.54 OpenSSL/0.9.7e
X-Powered-By: PHP/4.3.10-16
Expires: Tue, 1 Jan 1980 12:00:00 GMT
Last-Modified: Fri, 10 Mar 2006 21:12:27 GMT
Cache-Control: no-store, no-cache, must-revalidate, pre-check=0, post- check=0, max-age=0
Pragma: no-cache
Set-Cookie: cookiename=76604c55c52979f4230b6fb6416718b0; path=/
Transfer-Encoding: chunked

So, I'm a bit confused.

What I would expect monit to see is exactly what I would expect curl to see (curl is being run from localhost just as monit is).

Has anyone run into this? Anyone have any ideas?

I tried adding the -v switch, so I'm running
/usr/sbin/monit -Icv /etc/monit/monitrc

but that doesn't appear to change its logging behavior.

also does anyone know the status of the http host bug? i.e. the problem where monit does not send a HOST: header which breaks the http/1.1 spec?



alex black, founder
the turing studio, inc.


2600 10th street, suite 635
berkeley, ca 94710

reply via email to

[Prev in Thread] Current Thread [Next in Thread]