[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[monit] Problem Running Monit on Solaris 10

From: Andrew Ohnstad
Subject: [monit] Problem Running Monit on Solaris 10
Date: Sun, 13 Jan 2008 00:01:49 -0500

Hi all,

First time monit installer here...  Running on an x86 Solaris machine.

I installed monit from the "official" solaris package...

address@hidden:/etc# pkginfo|grep -i monit
application GNUmonit                     monit

But when I run monit I get:

address@hidden:/etc# /usr/local/bin/monit -c /etc/monitrc monit: fatal: open failed: No such file or directory

I have libssl as so:

address@hidden:/etc# find / -name

Originally I did not have the 'amd64' library path added, so i added it before the standard one:

address@hidden:/etc# crle

Configuration file [version 4]: /var/ld/ld.config  
  Default Library Path (ELF):   /lib:/usr/lib:/usr/sfw/lib/amd64:/usr/sfw/lib
  Trusted Directories (ELF):    /lib/secure:/usr/lib/secure  (system default)

But still no joy.

address@hidden:/etc# file /usr/local/bin/monit
/usr/local/bin/monit:   ELF 64-bit LSB executable AMD64 Version 1 [SSE2 SSE FXSR FPU], dynamically linked, stripped

address@hidden:/etc# file /usr/sfw/lib/amd64/
/usr/sfw/lib/amd64/     ELF 64-bit LSB dynamic lib AMD64 Version 1, dynamically linked, not stripped, no debugging information available

Any ideas before I pull the package and reinstall from source?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]