[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nel] Compiling nelns on linux

From: Julien Vermillard
Subject: Re: [Nel] Compiling nelns on linux
Date: 09 Nov 2002 22:37:00 +0100

I fixed the lib problem by creating the links but :

address@hidden:~/nel/nel$ ./configure

checking for STLPort headers... no
checking for main in -lstlport... yes
checking for STLPort library... /usr/lib
configure: error: STLPort must be installed (

address@hidden:~/nel/nel$ ls /usr/include/stlport
algorithm  config   cwchar       hash_set    iterator   new           
set        stdio_streambuf    time.h
bitset     csetjmp  cwctype      iomanip     limits     new.h         
setjmp.h   stdlib.h           typeinfo
cassert    csignal  deque        iomanip.h   list       numeric       
signal.h   stl                typeinfo.h
cctype     cstdarg  exception    ios         locale     old_hp        
slist      stl_user_config.h  using
cerrno     cstddef  exception.h  iosfwd      locale.h   ostream       
sstream    streambuf          utility
cfloat     cstdio   export       ios.h       map        ostream.h     
stack      streambuf.h        valarray
climits    cstdlib  fstream      iostream    math.h     pthread_alloc 
stdarg.h   string             vector
clocale    cstring  fstream.h    iostream.h  mem.h      pthread.h     
stddef.h   string.h           wchar.h
cmath      ctime    functional   istream     memory     queue         
stdexcept  strstream          wctype.h
complex    ctype.h  hash_map     istream.h   mmemory.h  rope          
stdio.h    strstream.h        wrap_std

Le mar 05/11/2002 à 19:42, Julien Vermillard a écrit :
> got exactly the same problem, tryed with debian packages 
> I finaly built STLport from source
> same result :(
> Le mar 05/11/2002 à 19:15, Merlin a écrit :
> > Ok, I'm hoping someone out there has successfully compiled nelns on 
> > linux.  I'm running Red Hat 8.0 and pulled STLport 4.5b8-1 from rpmfind.  I 
> > exmanded the tarball and ran ./bootstrap.  That worked with a few warnings 
> > about some things being deprecated.  I then ran ./configure 
> > --with-stlport=/usr, and it errors out with:
> > checking for STLPort headers... /usr/include/stlport
> > checking for main in -lstlport... no
> > checking for STLPort library... no
> > configure: error: STLPort must be installed (
> > 
> > Now, the STLport RPM I installed included the files listed in the attached 
> > file (too long for inline here).  Any suggestions/ideas on getting it past 
> > this first hurdle?
> > 
> > Thanks,
> > David 
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Nel mailing list
> > address@hidden
> >

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]