[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] 0.60 Solaris 9 problems.

From: Karel Gardas
Subject: Re: [Qemu-devel] 0.60 Solaris 9 problems.
Date: Mon, 13 Sep 2004 13:01:01 +0200 (CEST)

On Mon, 13 Sep 2004, Juergen Keil wrote:

> The java virtual machine included in Solaris x86 does not work
> for me.  When I start "java", I get:
>     % java
>     Error occurred during initialization of VM
>     java.lang.InternalError
> Tracing system calls (actually tracing signals) using "truss -t!all java"
> shows that the JVM gets a SIGSEGV signal when trying to access memory at
> address 0x0000001F, and crashes with the internal error after that.  I'm
> not sure if that's a bug in the java VM or a QEMU x86 CPU emulator bug.
> Sometimes a working java VM is needed at Solaris x86 installation time.
> For example with Solaris 10 x86, when you have a system with lots of memory,
> then a gui installer written in java is used, but it crashes with the above
> "InternalError" message.
> The solaris admin console (smc) also needs a working java VM.

JFYI: In the time when I got Solaris9/x86 running in Qemu I had also java
crashing issue with it, but then I have applied patch sent to qemu-users
to implement "no_ops" or something like that. The sender noted that it's
needed for Java and from this time, I was also able to start smc, although
it was horrible slow on my 1GHz x86 guest.


Karel Gardas                  address@hidden
ObjectSecurity Ltd.           http://www.objectsecurity.com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]