[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] SDL compile error

From: Jim C. Brown
Subject: Re: [Qemu-devel] SDL compile error
Date: Sun, 14 Nov 2004 19:20:28 -0500
User-agent: Mutt/1.4i

On Sun, Nov 14, 2004 at 07:45:59AM -0800, Shivkumar Shivaji wrote:
> /usr/lib/libSDL.a(SDL_fbevents.o)(.text+0x942): In function `find_pid':
> : undefined reference to `__ctype_b'
> /usr/lib/libSDL.a(SDL_fbelo.o)(.text+0x465): In function `eloSendQuery':
> : undefined reference to `__ctype_toupper'
> /usr/lib/libSDL.a(SDL_fbelo.o)(.text+0x5f1): In function `eloInitController':
> : undefined reference to `__ctype_tolower'
> collect2: ld returned 1 exit status

The above is where the actual errors are. This means that your SDL is based
on an older glibc (2.0 or something) but you have upgraded to a newer one
(2.3 or something). The undefined symbols are internal glibc symbols which the
dynamic loader knows how to resolve (via some hacks in the newer glibc) but
which the static linker can't. The real fix is to download SDL source and
recompile, that way the new SDL static library will not reference those symbols.

If you want a quick hack, compile the attached ctype_b.c file and link it into
qemu-fast. You will probably want to edit the Makefile to do this. (You can
also link it into libSDL.a I suppose. I haven't tried this so I do not
recommend it.)

> _______________________________________________
> Qemu-devel mailing list
> address@hidden
> http://lists.nongnu.org/mailman/listinfo/qemu-devel

Infinite complexity begets infinite beauty.
Infinite precision begets infinite perfection.

Attachment: ctype_b.c
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]