[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] linux-user target

From: Stuart Anderson
Subject: Re: [Qemu-devel] linux-user target
Date: Tue, 17 Apr 2007 16:55:06 -0400 (EDT)

On Tue, 10 Apr 2007, Jocelyn Mayer wrote:


I am unable to get any executable to run.

projects:~/upstream/qemu# ./ppc-linux-user/qemu-ppc -L /mirror0/chroots/ppc/ 
init_ppc_proc: PVR 00080000 mask ffffffff => 00080000
Segmentation fault

Just checked, on an amd64 host with a random powerpc bash version I got
on my hard disk drive:

-L /mnt/local/hdc/part3/PPC/linux/archives 
/mnt/local/hdc/part3/PPC/linux/archives/bin/bash --version
init_ppc_proc: PVR 00080000 mask ffffffff => 00080000
GNU bash, version 2.05a.0(1)-release (powerpc-unknown-linux-gnu)
Copyright 2001 Free Software Foundation, Inc.

I also tried to really launch the shell and use it and it worked.

... I have to admit there are some strange behaviors with some

But I think recent builds using glibc with TLS/NPTL would not run.

I've continued to work on this all week, and I still haven't managed to
solve it. I've chased down a lot of paths, but none of them have lead to
a solution. Here is a summary of the situation now.

 * programs other than bash will run
 * bash --version will run
 * bash --noediting will run
 * occasionally, bash has run if I'm stracing it, but I can't always
   reproduce it.
 * when it runs, I occasionally see some odd behavior, but not always.
   The termios patch I just sent cleared up a lot of the oddness.
 * when it runs, it hangs on exit. Killing it logs me all the way out
   of the system (ssh conection).
 * when it crashes, gdb looses the user level thread, so I can't do any
 * I don't see any of the TLS related system calls being called. I also
   don't see any concrete proof one way or another that it is used in
   the executable (ie No R_PPC_*TLS relocations). I've been digging in
   the kernel & glibc source, and I don't see a lot of special code to
   support TLS on ppc. It mostly seems to be just taking care to not
   step on R2. Glibc seems to be the only place where it knows something
   specific about TLS, which leads me to think that TLS is mostly
   contain within the userspace on PPC.
 * I've tried turning on most of the DEBUG_ defines under linux-user,
   but none of them has yielded anything useful, or noteworthy.


I'm in need a of a fresh idea or three.


Stuart R. Anderson                               address@hidden
Network & Software Engineering                   http://www.netsweng.com/
1024D/37A79149:                                  0791 D3B8 9A4C 2CDC A31F
                                                 BD03 0A62 E534 37A7 9149

reply via email to

[Prev in Thread] Current Thread [Next in Thread]