[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [patch] make qemu work with GCC 4

From: Johannes Schindelin
Subject: Re: [Qemu-devel] [patch] make qemu work with GCC 4
Date: Wed, 29 Aug 2007 17:55:05 +0100 (BST)


On Wed, 29 Aug 2007, Michael Matz wrote:

> On Wed, 29 Aug 2007, Johannes Schindelin wrote:
> > > Thanks for your effor Michael! Now, I only hope, one of the patches 
> > > that makes qemu gcc4 compliant are soon merged.
> > 
> > Well, to throw a spanner in the works: this patch is the 4th patch along 
> > the lines that I came about.  None of them (AFAICT) was tested well 
> > enough to be included in CVS.  Indeed, the biggest problem seems to be 
> > to make a patch that not only works on the machine of the poster, but on 
> > other machines, too.
> Please?  qemu with that patch builds on four architectures, and tests 
> fine on two of them (including cross targets) and only because I haven't 
> run it on the other two architectures yet.

Hey, I am not criticising you!  Instead, I am thankful enough that I went 
so far as to expose it with git.

> It might or might not need more patches than just mine (as I started 
> from our package), but in that case they are independend of making qemu 
> work with gcc 4, which is the only thing my patch is concerned about.

I already reported the non-compiling state of sparc-linux-user...  Any 
idea what I could do about it?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]