[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] qemu working openbsd/sparc64 yet?

From: Vivek Ayer
Subject: Re: [Qemu-devel] qemu working openbsd/sparc64 yet?
Date: Fri, 3 Apr 2009 14:02:49 -0700

okay i run: qemu-sparc -m 256 -boot d -cdrom linux.img using the
sample sparc-linux image and I get:

Illegal Instruction (core dumped).

Exactly, what steps did you take to get the linux image to run on
openbsd/sparc64. Could you show it with numbered steps so I can
troubleshoot and try to replicate your setup.


On Fri, Apr 3, 2009 at 12:49 PM, Vivek Ayer <address@hidden> wrote:
> That's weird because I'm using 4.3. Does QEMU expect X to be on when
> you run it? I'm doing this over ssh to a terminal and thought since I
> disable X support in Qemu, it would default to ncurses. In any case, I
> had a segfault when starting it trying to emulate opensolaris martux
> (SPARC/32-bit), which I guess is solaris 10, so I guess that could be
> the reason it didn't work. I'll try reproducing the error. Also, I
> didn't enable the sparc64 targets in the target list. I used
> ./configure --prefix=/usr/local --target-list="sparc-softmmu
> sparc-bsd-user" --disable-sdl --disable-gfx-check. I'll try the svn
> code, but I doubt that'll help.
> Vivek
> On Fri, Apr 3, 2009 at 9:58 AM, Blue Swirl <address@hidden> wrote:
>> On 4/3/09, Vivek Ayer <address@hidden> wrote:
>>> How did you build it without getting an error in sdl.c specifically at
>>>  X11/Xlib.h? I tried disabling sdl and it built fine, but the images
>>>  weren't loading, so I thought I'd go with the default options except
>>>  for the target list.
>> I'm using -current, but I didn't have compile problems with 4.1 (IIRC).
>> But this reminds me that I found a bug in SDL which made SDL apps
>> crash when running on Sparc with $DISPLAY pointing to x86 X server.
>> This bug was fixed in upstream SDL, but 4.1 still has the broken
>> version.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]