[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] quick version compatibility question ...

From: Michael Hannon
Subject: Re: [rdiff-backup-users] quick version compatibility question ...
Date: Fri, 1 Aug 2008 13:10:20 -0700
User-agent: Mutt/

On Fri, Aug 01, 2008 at 03:36:57PM -0400, Andrew Ferguson wrote:
> On Aug 1, 2008, at 12:58 PM, Juri Mianovich wrote:
> >I have rdiff-backup 1.0.4 deployed in multiple (server) locations.
> >
> >The client side of things is distributed and hard to get at.  They  
> >are all running 1.0.4 as well.
> >
> >I would like to deploy the new 1.2.0 release on my server side.
> >
> >Will the 1.0.4 clients out in the field continue to function  
> >properly if the server side suddenly warps to 1.2.0 ?  Will their  
> >data sets still be intact and continue to update and ... work ?
> No. The network protocol has changed from the 1.0.x series to the  
> 1.2.x series.

Hi, Andrew.  Is that "no" to both questions?  I.e., I assume that the
change in network protocol means that my existing rdiff cron jobs will
fail unless I update both server and clients to 1.2 simultaneously.

But what about the existing data?  Suppose I do update both server and
client to 1.2.  Can I then use the 1.2 client to restore files that were
saved when the 1.0 server and client were in use?  Or do I have to start
all over?


                                        - Mike
Michael Hannon            mailto:address@hidden
Dept. of Physics          530.752.4966
University of California  530.752.4717 FAX
Davis, CA 95616-8677

reply via email to

[Prev in Thread] Current Thread [Next in Thread]