[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Savannah-hackers] cvs problems...

From: Marcos Dione
Subject: [Savannah-hackers] cvs problems...
Date: Thu, 4 Jul 2002 19:20:47 -0300
User-agent: Mutt/1.4i

  hello. I'm experiencing problems to setup my cvs access properly.
  I'm using debian unstable, whose ssh version is:
OpenSSH_3.4p1 Debian 1:3.4p1-2, SSH protocols 1.5/2.0, OpenSSL 0x0090604f

  I read savanah's doc about how to set it up correctly. tell you what
I did.

  first of all, I put 'Protocol 1,2' in my .ssh/config file. then I
did a 'ssh-keygen -t rsa1', which created savanah.rsa1 and in .ssh dir. I 'copy & past'ed the .pub's content in waited a couple of
hours. then I do 'cvs -d address@hidden:/cvsroot/papo co
.' (styxman is my account name and papo is a project I'm a developer
of). cvs says:

address@hidden's password:
Permission denied, please try again.

  that is, after I entered the same passphrase I used when creating
the rsa1 files. I then realized that I should use *that* file and not
the default one. so, I tried a scp command; this is what I get:

address@hidden:~/src/work/fvl/tmp$ scp -v -1 -i ~/.ssh/savanah.rsa1 
address@hidden:/upload/papo/unstable.pkg/0.0.2/LEEME-CABEZA.txt .
Executing: program /usr/bin/ssh host, user styxman, 
command scp -v -f /upload/papo/unstable.pkg/0.0.2/LEEME-CABEZA.txt
OpenSSH_3.4p1 Debian 1:3.4p1-2, SSH protocols 1.5/2.0, OpenSSL 0x0090604f
debug1: Reading configuration data /home/mdione/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: ssh_connect: needpriv 0
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /home/mdione/.ssh/savanah.rsa1 type 0
debug1: Remote protocol version 1.99, remote software version lshd_1.4 lsh - a 
free ssh
debug1: no match: lshd_1.4 lsh - a free ssh
debug1: Local version string SSH-1.5-OpenSSH_3.4p1 Debian 1:3.4p1-2
debug1: Waiting for server public key.
debug1: Received server public key (768 bits) and host key (1024 bits).
debug1: Host '' is known and matches the RSA1 host key.
debug1: Found key in /home/mdione/.ssh/known_hosts:22
debug1: Encryption type: 3des
debug1: Sent encrypted session key.
debug1: cipher_init: set keylen (16 -> 32)
debug1: cipher_init: set keylen (16 -> 32)
debug1: Installing crc compensation attack detector.
debug1: Received encrypted confirmation.
debug1: RSA authentication using agent refused.
debug1: Trying RSA authentication with key '/home/mdione/.ssh/savanah.rsa1'
debug1: Server refused our key.
debug1: Doing challenge response authentication.
debug1: No challenge.
debug1: Doing password authentication.
address@hidden's password:

  notice that not only RSA auth fails, it even asks me for the passwd
and not the passphrase. what should I do?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]