[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tlf-devel] voicekeyer tlf-1.1pre2

From: Rob Vance
Subject: Re: [Tlf-devel] voicekeyer tlf-1.1pre2
Date: Wed, 2 Nov 2011 11:05:56 -0700

Hi Andy,

No apology required.  Yes, the short answer is that the sound card has several microphone inputs but the names are different.  I'm not at the machine now but I recall there are "front mic"& "rear mic" of various types, but none are called just plain "mic".

I should have reported back to Thomas:  Yes, commenting out the lines solved the problem and the keyer worked as expected without any complaints from amixer (in my code it was lines 1234 and 1236). It was a very satisfactory work-around as I don't use other mic inputs during contesting.  Alternatively I suppose I could have just renamed the entries in lines 1234/1236 to match my sound card and thus had the benefit of suppressing other sounds (mic inputs) during the voice keyer operation; but I have not tried this.

Thank you so much for the updates to the scoring and bandmap; I am still playing around with it, but I like it so far.

I have another question about the operation of the program, but I will post that separately as it is quite different from this topic.



On Wed, Nov 2, 2011 at 10:32 AM, Andy Summers <address@hidden> wrote:

Sorry about that, it was my fault. I just sent my hacks, to get it to do what I wanted it to do, over to Rein and they appeared in the code. I'm not confident enough to add in a config option for using the soundcard mic, so hopefully you might do that Tom? I presume that's what's needed?

Can you really get soundcards without a mic input? Or is it just called something slightly different on that soundcard?

73 Andy, G4KNO.

On Sat, Oct 29, 2011 at 7:39 AM, Thomas Beierlein <address@hidden> wrote:
Hi Rob,

Am Fri, 28 Oct 2011 21:45:04 -0700
schrieb Rob Vance <address@hidden>:
> I am using tlf on 11.04 (Natty Narwhal).  It's working fine except I
> am having a problem with the voice keyer.  When using either the
> auto-keyer or an F-key to send an audio track, I get this string on
> the screen.
> amixer: Unable to find simple control 'Mic',0

TLF tries to mute the microfone input on your soundcard.

The problem lies in the hardcoded assumption that there is such an
input device on your soundcard.

> I asked amixer to
> give me a list of devices and discovered that there is none called
> 'Mic' at all. So apparently tlf is calling a device called 'Mic' and
> amixer is telling it there is no such device (?).


> If so, can someone
> advise on a method to change this parameter?
As a quick fix I would suggest to comment out lines 1236 and 1238 in
src/callinput.c and recompile. That will drop the amixer invocation.
Keep an eye to the possibility to catch additional microfon input
signals during sending of one of the F-key audio tracks.

73, de Tom DL1JBE

> Hope everyone is enjoying CQ WW.
> 73,
> Rob, N6ROB

"Do what is needful!"
Ursula LeGuin: Earthsea

Tlf-devel mailing list

Tlf-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]