[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [XBoard-devel] gtk update

From: Arun Persaud
Subject: Re: [XBoard-devel] gtk update
Date: Tue, 14 Jun 2011 23:07:41 -0700
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110414 SUSE/3.1.10 Thunderbird/3.1.10


> Yes I think it's version issues. ubuntu 9.04 uses libgtk2.0-dev version 2.16. 
> 'gtk_file_chooser_set_create_folders' is only available in 2.18 and later.
> I commented out that line (5082) in xboard.c and it compiled ok. It then 
> fails at run time though with:
> Error: 7 gtk/evalgraph.glade: required gtk+ version 2.20, current version is 
> 2.16
> Error: gtk_builder didn't work (EvalGraph)!
> Error: gtk_builder didn't work (EvalGraphDrawingArea)!
> so the glade file requires version 2.20.

should work now with 2.16 (just uploading to git and the build server).
Commented out the ...set_create_folder and changed the glade files to
version >=2.16.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]