[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX-devel] problems with make install for auctex-11.84 with XEma

From: Daniel Winkelmann
Subject: Re: [AUCTeX-devel] problems with make install for auctex-11.84 with XEmacs on WinXP
Date: Fri, 21 Dec 2007 13:24:03 +0100

Ralf Angeli wrote:

and I ran configure again with MSYS
./configure --prefix="D:/XEmacs"

again configure and make worked without complaint but make install
finishes with the same errors but not the "unbalanced parentheses"

How can it finish with the same errors if the error about unbalanced
parentheses is missing?

Sorry, my mistake for not being precise enough, it finishes with the same error-messages (not comprehensible to me: Error 1 and Error 2 as reported) but obviously a bit farther down the line.

and when I open a *.tex document with Xemacs I now do get the menus.
dont' kow yet if other things will fail to work because install

Me neither.  But you should stay clear of UTF-8 files with a no-MULE

It was not obvious to me that the file I downloaded from


would be UTF-8 and no-MULE, neither do I know what that means and implies as consequences.

should I run make install again?

You will likely get the same errors, so I doubt this will help.

should I send you config.log ?

Yes, it might give some hints.

doesn't seem to write a log and I don't know how to  cut and paste
of  the MSYS window.

You can use `tee' to redirect the output to a file.  I currently don't
have time to look up the syntax, nor do I know if it is included in
MSYS.  Especially the error messages at the bottom are essential for
debugging.  Without those config.log will not help much.

ok, tee is available but didn't write all the lines into the install.log I created with

make install | tee install.log

the last 30 lines (about 300) where shown in the MSYS window but not in the log. Please tell me if you really want all 300 lines, here are the last 11 lines:

Generating autoloads for toolbar-x.el...
Wrote d:\XEmacs\site-packages\lisp\auctex\auto-autoloads.el
Mark set
Wrote d:\XEmacs\site-packages\lisp\auctex\auto-autoloads.el
Compiling d:\XEmacs\site-packages\lisp\auctex\auto-autoloads.el...
Compiling auto-autoloads.el... (TeX-modes-set)
Compiling d:\XEmacs\site-packages\lisp\auctex\auto-autoloads.el...done
Wrote d:\XEmacs\site-packages\lisp\auctex\auto-autoloads.elc
make[1]: *** [install-metadata] Error 1
make[1]: Leaving directory `/d/auctex-11.84'
make: *** [install] Error 2

BTW, if you want to be sure to have a fully working AUCTeX, you could
download the AUCTeX XEmacs package from the AUCTeX homepage and simply
drop this into your package tree.  This will spare you the hassles of
configuring and building.

I didn't find an AUCTeX-XEmacs package for MS Windows (winXP in my case).

I will report any misfunctions I'll observe with more use of my XEmacs-AUCTeX installation in 2008, for the time being, happy holidays !


reply via email to

[Prev in Thread] Current Thread [Next in Thread]