[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest CVS - possible serious bug using it in UnixWare 7.1.1

From: Matt Schalit
Subject: Re: Latest CVS - possible serious bug using it in UnixWare 7.1.1
Date: Tue, 30 Jan 2001 02:17:32 -0800

Akim Demaille wrote:
> >>>>> "Matt" == Matt Schalit <address@hidden> writes:
> Matt> Thank you for the rapid reply and your suggestions, Akim.
> You are welcome.
> Frankly, I think your diagnostic is wrong somewhere.
> 1. The error message is clearly from GNU M4 (trust me, I know it's
>    messages :).  SunOS's just loops and trashes its stack.
> 2. autoconf checks that the underlying M4 is GNU M4.
> So something else is wrong.

You think that somehting else is wrong, but I only changed
one two variables in my whole entire system.

  Case 1)  Linked /usr/bin/m4  to /usr/local/bin/m4.
           Autoconf cvs finds /usr/bin/m4.
           Autoconf cvs determines /usr/bin/m4 = Gnu M4.
           autoconf -l . gives the error listed.

  Case 2)  Linked /usr/bin/m4 to /usr/ccs/bin/m4
           Linked /usr/local/bin/m4  to /usr/local/bin/gm4
           Autoconf cvs looks for gm4 first before /usr/bin/m4.
           Autoconf cvs finds gm4 is Gnu-M4
           autoconf -l . is no problem

I don't know the guts of these programs, so it'd be a waste
of time for me to conjecture about what it could be.

It's easy enough for me to recreate both cases, and I'd
be glad to do so and follow your suggestion, so that you
can see the m4-$$.log output.   I have a feeling that you're
curious about this.  Just let me know, or I'll move on.

I just guessed that you'd want to move on, once you saw
that I had altered a symlink that probably nobody else does.

Btw, one of the ways I determined that it was the build
of cvs autoconf that was causing me grief was to remove
it, while changing nothing else, and to compile and install
autconf 2.13.  I found that 2.13 worked fine with no changes,
that is, I was still in Case 1 with the bad symlink.  So if 2.13
worked, but cvs autoconf didn't, then I had a suspect.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]