[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: configure and gcc

From: Ralf Wildenhues
Subject: Re: configure and gcc
Date: Mon, 6 Nov 2006 22:53:15 +0100
User-agent: Mutt/1.5.13 (2006-08-11)

Hello David,

* address@hidden wrote on Sun, Nov 05, 2006 at 02:52:39AM CET:
> I am trying to incorporate configure into a hc12 library rework of  
> libgel.  In the original by Stephane Carre, he didn't use autoconf.  I  
> want to  try and configure GCC version (m6812-elf-gcc) instead of gcc.  
>  I tried using AC_PROG_CC() but it doesn't like my other variables  
> and runs all over my config.

This is a bit thin for a decent error description.  What does AC_PROG_CC
do that is wrong for you?  And why do you need TARGET_CC?  Are you
really trying to compile a compiler package using a Canadian Cross or
similar?  (I'd assume that if you were, you wouldn't be asking this

If the package you are trying to compile isn't itself a compiler, then
you have no need for TARGET-something.  Maybe you just want to use
AC_PROG_CC and use
  ./configure --host=m6812-elf

to invoke cross-compilation mode and use a compiler named m6812-elf-gcc?

> I tried this and it gave me errors on automake --force

Automake sticks an
at the end of AC_PROG_CC, and needs this for its dependency tracking.

> Here is my snippet
> AC_ARG_VAR([TARGET_CPP],[target cpp program])
>               [${target_alias}gcc],
>               [${target_alias}gcc],

Isn't the tool prefix usually some alias plus a hyphen '-'?

>               [NO],
>               [$PATH],
>               [exit])
> AC_ARG_VAR([TARGET_GCC],[target gcc program])
> echo $TARGET_GCC
> {this sets target_alias properly and TARGET_GCC}
> and then inside my  I used this
> If I leave out src/Makefile from AC_CONFIG_FILES([]) I get no error.

You should also be able to stick the Automake option no-dependencies
into AM_INIT_AUTOMAKE to avoid the error.

> autoreconf: running: automake-1.9 --add-missing --copy --force-missing
> /usr/share/automake-1.9/am/ am__fastdepCC does not appear  
> /usr/share/automake-1.9/am/ AMDEP does not appear in 
> autoreconf: automake-1.9 failed with exit status: 1

Hope that helps.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]